MalgraBooks

All systems are operational.

Affected components

1 month ago
Fixed
Affected Components: Transactional Email Service

Fixed

1 month ago

This has been resolved by Amazon Web Services and emails are now sending as planned.

Reported

1 month ago

We're aware of a delay with emails being sent from Pulse to reset passwords - we have identified that this issue is related to an outage with Amazon Web Server and is being looked into